  <!DOCTYPE html>
<html>
    <head>
        <!-- Meta tags -->
        <meta charset="utf-8">
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
        <!-- <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"> -->
        <meta name="viewport" content="width=device-width, initial-scale=1">
        <title>A readable Thread by @QuinnyPig Says Time to put on my Cloud Economics Pant - UnrollThread.com</title>
        <meta name="msapplication-TileColor" content="#ffffff">
        <meta name="msapplication-TileImage" content="/wp-content/themes/UnrollThread/assets/images/iconsLogos/favicon/ms-icon-144x144.png">
        <meta name="theme-color" content="#ffffff">
        <!--favincon-->
        <link rel="apple-touch-icon" sizes="57x57" href="/wp-content/themes/UnrollThread/assets/images/iconsLogos/favicon/apple-icon-57x57.png">
        <link rel="apple-touch-icon" sizes="60x60" href="/wp-content/themes/UnrollThread/assets/images/iconsLogos/favicon/apple-icon-60x60.png">
        <link rel="apple-touch-icon" sizes="72x72" href="/wp-content/themes/UnrollThread/assets/images/iconsLogos/favicon/apple-icon-72x72.png">
        <link rel="apple-touch-icon" sizes="76x76" href="/wp-content/themes/UnrollThread/assets/images/iconsLogos/favicon/apple-icon-76x76.png">
        <link rel="apple-touch-icon" sizes="114x114" href="/wp-content/themes/UnrollThread/assets/images/iconsLogos/favicon/apple-icon-114x114.png">
        <link rel="apple-touch-icon" sizes="120x120" href="/wp-content/themes/UnrollThread/assets/images/iconsLogos/favicon/apple-icon-120x120.png">
        <link rel="apple-touch-icon" sizes="144x144" href="/wp-content/themes/UnrollThread/assets/images/iconsLogos/favicon/apple-icon-144x144.png">
        <link rel="apple-touch-icon" sizes="152x152" href="/wp-content/themes/UnrollThread/assets/images/iconsLogos/favicon/apple-icon-152x152.png">
        <link rel="apple-touch-icon" sizes="180x180" href="/wp-content/themes/UnrollThread/assets/images/iconsLogos/favicon/apple-icon-180x180.png">
        <link rel="icon" type="image/png" sizes="192x192" href="/wp-content/themes/UnrollThread/assets/images/iconsLogos/favicon/android-icon-192x192.png">
        <link rel="icon" type="image/png" sizes="32x32" href="/wp-content/themes/UnrollThread/assets/images/iconsLogos/favicon/favicon-32x32.png">
        <link rel="icon" type="image/png" sizes="96x96" href="/wp-content/themes/UnrollThread/assets/images/iconsLogos/favicon/favicon-96x96.png">
        <link rel="icon" type="image/png" sizes="16x16" href="/wp-content/themes/UnrollThread/assets/images/iconsLogos/favicon/favicon-16x16.png">
        <meta property="og:title" content="A readable Thread by @QuinnyPig Says Time to put on my Cloud Economics Pant - UnrollThread.com" />
        <meta property="og:image" content="https://s.unrollthread.com/UserContent/ThreadPic/1443416138675671045.png" />
        <meta property="og:image:alt" content="UnrollThread" />
        <meta property="og:url" content="https://UnrollThread.com/t/1443028078196711426" />
        <meta property="og:description" content="A readable Tweet Thread is waiting for you @QuinnyPig Says Time to put on my Cloud Economics Pants and do a bit of math around @Cloudflare's R2 pricing model as described herein. 

https://t.co/bCcf1mTIT7" />
        <meta property="article:author" content="https://twitter.com/QuinnyPig" />
        <meta property="twitter:card" content="summary_large_image" />
        <meta property="twitter:creator" content="@QuinnyPig" />
        <meta property="twitter:image" content="https://s.unrollthread.com/UserContent/ThreadPic/1443416138675671045.png" />
        <meta property="twitter:description" content="A readable Tweet Thread is waiting for you @QuinnyPig Says Time to put on my Cloud Economics Pants and do a bit of math around @Cloudflare's R2 pricing model as described herein. 

https://t.co/bCcf1mTIT7" />
        <meta property="og:image:width" content="1200" />
        <meta property="og:image:height" content="628" />
        <meta property="og:image:type" content="image/png" />
        <meta property="og:type" content="article" />

        <!-- Bootstrap, Font Awesome, Aminate, Owl Carausel, Normalize CSS -->
        <link href="/wp-content/themes/UnrollThread/assets/med/css/bootstrap.css" rel="stylesheet">
        <link href="/wp-content/themes/UnrollThread/assets/med/css/owl.carousel.min.css" rel="stylesheet">
        <link href="/wp-content/themes/UnrollThread/assets/med/css/owl.theme.default.min.css" rel="stylesheet">

        <!-- Site CSS -->
        <link href="/wp-content/themes/UnrollThread/assets/med/css/style.css" rel="stylesheet">
        <link href="/wp-content/themes/UnrollThread/assets/med/css/widgets.css" rel="stylesheet">
        <link href="/wp-content/themes/UnrollThread/assets/med/css/color-default.css" rel="stylesheet">
        <link href="/wp-content/themes/UnrollThread/assets/med/css/responsive.css" rel="stylesheet">
        <!-- Google fonts-->
        <link href="https://fonts.googleapis.com/css?family=Cabin:400,700&display=swap" rel="stylesheet">
        <link href="https://fonts.googleapis.com/css?family=B612+Mono&display=swap" rel="stylesheet">
        <link href="https://fonts.googleapis.com/css?family=Lora:400,400i,700,700i&display=swap" rel="stylesheet">

        <!-- Icons fonts-->
        <link href="/wp-content/themes/UnrollThread/assets/med/css/fontello.css" rel="stylesheet">
        <link href="/wp-content/themes/UnrollThread/assets/med/css/font-awesome.min.css" rel="stylesheet">
<script data-ad-client="ca-pub-5626313167504720" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
    </head>

<body class="single">

<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><script>  window.onload = (function(){
  });</script><div class="top-scroll-bar"></div>
<!--Mobile navigation-->
<div class="sticky-header fixed d-lg-none d-md-block">
    <div class="text-right">
        <div class="container mobile-menu-fixed pr-5">
            <h1 class="logo-small navbar-brand"><a href="/" class="logo">Unroll Thread</a></h1>

            <!-- <a class="author-avatar" href="#"><img src="/wp-content/themes/UnrollThread/assets/med/images/author-avata-1.jpg" alt=""></a> -->

            <ul class="social-network heading navbar-nav d-lg-flex align-items-center" style="margin-right: 60px">
                <li><a href="https://twitter.com/UnrollThread"><i class="icon-twitter"></i></a></li>
            </ul>

            <label class="theme-selector mobile">
                <input type="checkbox" class="js-themeToggle">
                <i class="gg-sun"></i>
                <i class="gg-moon"></i>
            </label>

            <a href="javascript:void(0)" class="menu-toggle-icon">
                <span class="lines"></span>
            </a>
        </div>
    </div>

    <div class="mobi-menu">
        <div class="mobi-menu__logo">
            <h1 class="logo navbar-brand"><a href="/" class="logo">Unroll Thread</a></h1>
        </div>
        <!-- <form action="#" method="get" class="menu-search-form d-lg-flex">
            <input type="text" class="search_field" placeholder="Search..." value="" name="s">
        </form> -->
        <!-- <nav>
            <ul>
                <li class="current-menu-item"><a href="/">Home</a></li>
                <li class="menu-item-has-children"><a href="categories.html">Categories</a>
                    <ul class="sub-menu">
                        <li><a href="categories.html">Politics</a></li>
                        <li><a href="categories.html">Health</a></li>
                        <li><a href="categories.html">Design</a></li>
                    </ul>
                </li>
                <li><a href="typography.html">Typography</a></li>
                <li><a href="categories.html">Politics</a></li>
                <li><a href="categories.html">Health</a></li>
                <li><a href="contact.html">Contact</a></li>
            </ul>
        </nav> -->
    </div>
</div>
<!--Mobile navigation-->
<div id="wrapper">
    <header id="header" class="d-lg-block d-none">
        <div class="container">
            <div class="align-items-center w-100">
                <h1 class="logo float-left navbar-brand"><a href="/" class="logo">Unroll Thread</a></h1>
                <div class="header-right float-right w-50">
                    <div class="d-inline-flex float-right text-right align-items-center">
                        
                        
                        <label class="theme-selector mobile">
                            <input type="checkbox" class="js-themeToggle">
                            <i class="gg-sun"></i>
                            <i class="gg-moon"></i>
                        </label>
                        <ul class="social-network heading navbar-nav d-lg-flex align-items-center">
                          <li><a href="https://twitter.com/UnrollThread"><i class="icon-twitter"></i></a></li>
                        </ul>
                        <!-- <ul class="top-menu heading navbar-nav w-100 d-lg-flex align-items-center">
                            <li><a href="#" class="btn">Contact</a></li>
                        </ul> -->
                        <!-- <a class="author-avatar" href="#"><img src="/wp-content/themes/UnrollThread/assets/med/images/author-avata-1.jpg" alt=""></a> -->
                    </div>
                    <!-- <form action="#" method="get" class="search-form d-lg-flex float-right">
                        <a href="javascript:void(0)" class="searh-toggle">
                            <i class="icon-search"></i>
                        </a>
                        <input type="text" class="search_field" placeholder="Search..." value="" name="s">
                    </form> -->
                </div>
            </div>
            <div class="clearfix"></div>
        </div>
        <!-- <nav id="main-menu" class="stick d-lg-block d-none">
            <div class="container">
                <div class="menu-primary"> -->
                    <!-- <ul>
                        <li class="current-menu-item"><a href="/">Home</a></li> -->
                        <!-- <li class="menu-item-has-children"><a href="categories.html">Categories</a>
                            <ul class="sub-menu">
                                <li><a href="categories.html">Politics</a></li>
                                <li><a href="categories.html">Health</a></li>
                                <li><a href="categories.html">Design</a></li>
                            </ul>
                        </li> -->
                        <!-- <li><a href="typography.html">Typography</a></li>
                        <li><a href="categories.html">Politics</a></li>
                        <li><a href="categories.html">Health</a></li>
                        <li><a href="categories.html">Design</a></li>
                        <li><a href="categories.html">Startups</a></li>
                        <li><a href="categories.html">Culture</a></li>
                        <li><a href="contact.html">Contact</a></li> -->
                        <!-- <li class="menu-item-has-children"><a href="#">More...</a>
                            <ul class="sub-menu">
                                <li><a href="search.html">Search</a></li>
                                <li><a href="author.html">Author</a></li>
                                <li><a href="404.html">404</a></li>
                            </ul>
                        </li> -->
                    <!-- </ul> -->
                    <!-- <span></span>
                </div>
            </div>
        </nav> -->
    </header>
<main id="content">
  <div class="container">
    <div class="entry-header">
        <div class="mb-5">
            <!-- <h1 class="entry-title m_b_2rem">
            Thread : <a href="https://twitter.com/QuinnyPig/status/1443028078196711426" target="_blank">1443028078196711426</a>
            </h1> -->
            <div class="entry-meta align-items-center">
                <a class="author-avatar" href="https://twitter.com/QuinnyPig"><img src="https://pbs.twimg.com/profile_images/1431046769262006274/7GJFLo-A_bigger.jpg" alt="@QuinnyPig - Corey Quinn"></a>
                <a href="https://twitter.com/QuinnyPig">Corey Quinn</a> at <a href="https://twitter.com/QuinnyPig/status/1443028078196711426"><strong>@</strong>QuinnyPig</a><br>
                <span>15 Tweets</span>
                <span class="middotDivider"></span>
                <span class="readingTime" title="2 minutes, 15 seconds min read">2 minutes, 15 seconds read</span>
                <span class="svgIcon svgIcon--star">
                    <svg class="svgIcon-use" width="15" height="15">
                        <path d="M7.438 2.324c.034-.099.09-.099.123 0l1.2 3.53a.29.29 0 0 0 .26.19h3.884c.11 0 .127.049.038.111L9.8 8.327a.271.271 0 0 0-.099.291l1.2 3.53c.034.1-.011.131-.098.069l-3.142-2.18a.303.303 0 0 0-.32 0l-3.145 2.182c-.087.06-.132.03-.099-.068l1.2-3.53a.271.271 0 0 0-.098-.292L2.056 6.146c-.087-.06-.071-.112.038-.112h3.884a.29.29 0 0 0 .26-.19l1.2-3.52z"></path>
                    </svg>
                </span>
            </div>
            <div class="entry-bottom">
                                    <div class="tags-wrap heading">
                                        <span class="tags">
                                          <div class="bookpdfauthor">
                                          </div>
                                          </span>
                                    </div>
                                </div>
        </div>
    </div> <!--end single header-->
    <article class="entry-wraper mb-5">
        <div class="entry-left-col">
            <div class="social-sticky">
              <a href="https://www.facebook.com/sharer/sharer.php?u=https://unrollthread.com/t/1443028078196711426" target="_blank"><i class="icon-facebook"></i></a>
                <a href="http://twitter.com/share?text=A readable Thread by @QuinnyPig Says Time to put on my Cloud Economics Pant&url=https://unrollthread.com/t/1443028078196711426&hashtags=Thread,UnrollThread" target="_blank"><i class="icon-twitter"></i></a>
                <!-- <a href="#"><i class="icon-heart"></i></a>
                <a href="#"><i class="icon-paper-plane"></i></a> -->
            </div>
        </div>
        <!-- <div class="excerpt mb-4">
            <p>Gosh jaguar ostrich quail one excited dear hello and bound and the and bland moral misheard roadrunner flapped lynx far that and jeepers giggled far and far bald that roadrunner python inside held shrewdly the manatee.</p>
        </div> -->
        <div class="entry-main-content dropcap">
          <!--  -->
          <p> Time to put on my Cloud Economics Pants and do a bit of math around @Cloudflare's R2 pricing model as described herein. 

  <p><blockquote class="embedly-card" data-card-controls="0" data-card-key="1d5c48f7edc34c54bdae4c37b681ea2b"><h4>
<a href="https://blog.cloudflare.com/introducing-r2-object-storage/">blog.cloudflare.com/introducing-r2…</a></blockquote><div class="row"></div>              <hr class="section-divider"><p> So today I'm going to store 1GB of data in @awscloud's S3 and serve it out to the internet. The storage charge is 2.3¢ per month the tier 1 regions. <p><div class="row"></div>              <hr class="section-divider"><p> Someone on the internet grabs that 1GB of data once. I'm paying 9¢ to send it to them. You read that right; just shy of four months' of storage charges to send it to the internet once. <p><div class="row"></div>              <hr class="section-divider"><p> As described, R2 sits in CloudFlare's world. The first time you request an object from S3 via CloudFlare, I pay 9¢ to send it out, then 1.5¢ a month to keep it in R2. <p><div class="row"></div>              <hr class="section-divider"><p> And from that point forward egress becomes free. But I'm not done. <p><div class="row"></div>              <hr class="section-divider"><p> Now look, @eastdakota strikes me as a stand-up guy, but he's a network guy; my data is SUPER important. I want to keep it on S3. <p><div class="row"></div>              <hr class="section-divider"><p> I can cut it over to use S3 Infrequent Access. This drops the price on AWS to 1.25¢ per GB per month. Should R2 break and need to re-retrieve it again, I'll pay another 9¢ to transfer it out, plus a 1¢ surcharge for retrieving it from Infrequent Access. <p><div class="row"></div>              <hr class="section-divider"><p> Let's tie this together. I can pay 2.3¢ per GB plus a whopping 9¢ per GB of transfer, *OR* I can pay 2.75¢ per GB to keep it in both places, secure in the knowledge that my egress traffic is a one-time 9¢ charge, the end. <p><div class="row"></div>              <hr class="section-divider"><p> Would I take that deal?

Dear reader, yesterday I would have sold you for glue in order to secure that deal. Today I don't have to. <p><div class="row"></div>              <hr class="section-divider"><p> The only response @awscloud realistically has is to significantly cut their egress pricing in one form or another, in which case customers win.

(A "surcharge to CloudFlare" or whatnot would destroy trust in their business and is untenable.) <p><div class="row"></div>              <hr class="section-divider"><p> This is frankly brilliant of @Cloudflare. I'm just waiting for an astroturf campaign ineptly trying to cast shade their way about how dangerous / risky their object storage is, but as mentioned upthread I can mitigate data loss risk by keeping it both places simultaneously. <p><div class="row"></div>              <hr class="section-divider"><p> All of this is of course the worst case cost model if you distrust @Cloudflare not to lose data. Trust it (something that comes with longevity) and the economics improve by a lot. <p><div class="row"></div>              <hr class="section-divider"><p> One final point: Now let’s remember that the internet is 1-to-many. If 1 million people download that 1GB this month, my cost with @cloudflare R2 this way rounds up to 13¢. With @awscloud S3 it’s $59,247.52. 

THAT is why people are losing their minds over this. <p><div class="row"></div>              <hr class="section-divider"><p> Slight correction: $53,891.16. Apologies, the @awscloud pricing calculator LOVES to slip "developer support" onto the tab. <p><div class="row"></div>              <hr class="section-divider">          <div id="myModal" class="modal fade"  tabindex="-1" role="dialog" aria-hidden="true">
    <div class="modal-dialog">
        <div class="modal-content">
          <div class="modal-header">
      <button type="button" class="close" data-dismiss="modal" aria-label="Close">
        <span aria-hidden="true">&times;</span>
      </button>
    </div>
            <div class="modal-body">
                <img class="showimage img-responsive" src="" />
            </div>
            <div class="modal-footer">
       <button type="button" class="btn btn-secondary" data-dismiss="modal">Close</button>
     </div>
        </div>
    </div>
</div>

          <div class="box box-author m_b_2rem">
            <div class="post-author row-flex">
                <div class="author-img">
                    <img alt="author avatar" src="https://pbs.twimg.com/profile_images/1431046769262006274/7GJFLo-A_bigger.jpg" alt="@QuinnyPig - Corey Quinn" class="avatar">
                </div>
                <div class="author-content">
                <div class="top-author">
                    <h5 class="heading-font"><a href="https://twitter.com/QuinnyPig" title="@QuinnyPig - Corey Quinn" rel="author">Corey Quinn</a></h5></div>
                    <div class="content-social-author">
                                                                    <a target="_blank" class="author-social" href="https://twitter.com/QuinnyPig">Followers 69.8k</a>
                                                                    <a target="_blank" class="author-social" href="https://twitter.com/QuinnyPig">Following 702</a>
                                                                </div>
                    <!-- <p class="d-none d-md-block">Lorem ipsum dolor sit amet, consectetur adipiscing elit. Suspendisse laoreet ut ligula et semper. Aenean consectetur, est id gravida venenatis.</p> -->
                    <div class="content-social-author">
                        <!-- <a target="_blank" class="author-social" href="#">Facebook </a> -->
                        <a target="_blank" class="author-social" href="https://twitter.com/QuinnyPig">Twitter : @QuinnyPig</a>
                        <!-- <a target="_blank" class="author-social" href="#"> Google + </a> -->
                    </div>
                </div>
            </div>
        </div>
    </article> <!--entry-content-->






  </div>
</main>
<div id="BtnLoadData"></div>
</div>
<!--wrapper div-->
<a href="#" class="back-to-top heading"><i class="icon-left-open-big"></i><span  class="d-lg-inline d-md-none">Top</span></a>

<!--Scripts-->
<script src="/wp-content/themes/UnrollThread/assets/js/dark-mode.js"></script>
<script src="/wp-content/themes/UnrollThread/assets/med/js/jquery.min.js"></script>
<script src="/wp-content/themes/UnrollThread/assets/med/js/bootstrap.js"></script>
<script src="/wp-content/themes/UnrollThread/assets/med/js/jquery-scrolltofixed-min.js"></script>
<script src="/wp-content/themes/UnrollThread/assets/med/js/theia-sticky-sidebar.js"></script>
<script src="/wp-content/themes/UnrollThread/assets/med/js/scripts.js"></script>
<script async src="//cdn.embedly.com/widgets/platform.js" charset="UTF-8"></script>
<script>
$(document).ready(function () {
    $('img').on('click', function () {
        var image = $(this).attr('src');
        //alert(image);
        $('#myModal').on('show.bs.modal', function () {
            $(".showimage").attr("src", image);
        });
    });
});
</script>
<script type="text/javascript">
$(document).ready(function() {

    var ButtonDownURL='/userbuttonsdisplay/?ru=https://unrollthread.com/t/1443028078196711426&tid=1443028078196711426';
    var postData='';
        $.ajax({
								url : ButtonDownURL,
								type: "POST",
								data : postData,
								success:function(data, textStatus, jqXHR)
								{
                                    // $("#loaderIMG").slideUp(500);
                                    $("#BtnLoadData").html(''+data+'');


								},
								error: function(jqXHR, textStatus, errorThrown)
								{
									$("#BtnLoadData").html('PDF Download Button error');
								}
							});
			});

</script>


</body>
</html>
